[antlr-interest] Re: Request enhancement ANTLR

Terence Parr parrt at jguru.com
Sat Sep 14 22:11:36 PDT 2002

On Saturday, September 14, 2002, at 09:57  PM, Brian Smith wrote:

> Terence,
> May I recommend that instead of getFilename/setFilename, you have 
> getURL
> and setURL()? I am using ANTLR inside of NetBeans and I've added an
> extension just as you described. With NetBeans they have a filesystem
> abstraction that uses URL's of the form nbfs://XXXX to identify files,
> so I can't use a "filename" per se. Also, get/setFilename wouldn't be
> very useful for parsing from a HTTP stream.


Hmm...well, getInputName or some such would work.  i'm worried that URL 
would make people think you needed file:// on the front or something.  
Can you just use the method knowing it's a bit of a misnomer?

What are you doing with NetBeans?  A cool secret project?

Co-founder, http://www.jguru.com
Creator, ANTLR Parser Generator: http://www.antlr.org


Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/ 

More information about the antlr-interest mailing list