[antlr-interest] Issue with antlrworks 1.3.1 and JDK 1.6 update 17?

Michael Richter ttmrichter at gmail.com
Tue Jan 12 18:30:50 PST 2010

Off the top of my head 2 and 3 are confirmed.  I run my own copy of the Sun
JDK in my user directory precisely because of the whole GNU "java" compiler
fiasco.  gjc is not on my path anywhere and java points to
~/software/jdk<stuff>/bin/java.  And I only ever actually use antlrworks
from the command line (as an alias, to be fair) so it's the only way I can
show you how it's running.  ;)

I'll test the heap memory thing now, though.

....And we're back.  The behaviour is identical with 1GB of heap memory on
both Windows and Linux.

2010/1/13 Warren Wilbur <wwilbur3 at yahoo.com>

> Here are a few debugging ideas as I've seen each of these issues before...
> 1. Try increasing the heap memory for Java on the command line. e.g. to
> increase to 1GB use: java -Xmx1024M -jar antlrworks-1.3.1.jar
> 2. Check if you are really using the Sun Java JRE/JDK on Ubuntu Linux (this
> will give you the right idea:
> http://www.cyberciti.biz/faq/howto-ubuntu-linux-install-configure-jdk-jre)
> . If multiple alternatives are installed you might not be... Using another
> JRE/JDK could be the cause of your problems.
> 3. Run antlrworks by command line from a terminal. If you have any 'out of
> memory' errors you will see console messages in the Ubuntu terminal you
> executed it from.
> Date: Wed, 6 Jan 2010 19:33:23 +0800
> From: Michael Richter <ttmrichter at gmail.com>
> Subject: [antlr-interest] Issue with antlrworks 1.3.1 and JDK 1.6
>     update 17?
> To: antlr-interest at antlr.org
> Message-ID:
>     <ee970b291001060333j78fde473nfc0efad9fa93b03f at mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
> I did a recent round of upgrading software on my machines (real and
> virtual)
> and somewhere in the process I've got ANTLRworks in unusable shape.  (I
> tried reporting this through the antlr.org web site but it doesn't seem to
> have taken.)
> On *every* machine I have access to (both real and virtual, running Windows
> XP or Linux) I get the following pretty nasty behaviour:
>    1. *java -jar antlrworks.jar* (I can also use javaw on Windows for a
>    similar, more annoying effect.)
>    2. *The splash screen pops up briefly.*
>    3. *The "New Document" dialogue replaces it.*
>    4. I hit "Cancel" (or alternatively press "Esc" on the keyboard).
> At this point, no matter the platform, no matter what I try, I have a dead
> executable until I hit Ctrl+C (or, if I used javaw, I kill it in the task
> manager).  I've tried this on Ubuntu 9.04, on Slackware 13.0 (virtualized),
> on Windows XP (four different machines, one virtualized) and get this
> behaviour consistently.  Whatever's supposed to happen when I cancel the
> new
> document dialogue freezes and can only unfreeze through lethal injection of
> Ctrl+C.  (There are, of course, no messages on the console that could tell
> me what's going on.)
> The behaviour on Windows after this if I choose "OK" is acceptable.  Up
> comes the wizard for a new project which works normally and, more
> importantly, can be cancelled and gets me into the ANTLRworks GUI.  It's a
> bit obnoxious having to go that route, but it works.  If I choose to use
> the
> wizard everything works as expected.
> The behaviour on Linux is less acceptable.  The new project wizard pops up
> but the text input focus is on ANTLRworks' editor window and CANNOT be put
> into the wizard at all on any spot.  I have to cancel the wizard to get to
> the main window (which then works as expected).  This also happens if I go
> File -> New from the main window: I simply cannot get text input into any
> field of the new project wizard.
> The last time I did anything with ANTLRworks was v1.3.0 using JDK 1.6
> update
> 16.  I did not see this behaviour then at all, so something has happened
> between then and now.
> Any advice for debugging this further?
> List: http://www.antlr.org/mailman/listinfo/antlr-interest
> Unsubscribe:
> http://www.antlr.org/mailman/options/antlr-interest/your-email-address

More information about the antlr-interest mailing list